Hướng dẫn cài đặt & Review Solarwinds Network Performance Monitor (NPM)

Kiến Thức

Bài viết sẽ hướng dẫn & Review cài đặt chi tiết phần mềm Solarwinds Network Performance Monitor (NPM) với môi trường lab được setup trước.

Chúng tôi cũng sẽ thiết lập môi trường lab để cài đặt và định cấu hình Solarwinds Network Performance Monitor (NPM) để giám sát một số thiết bị.

Solarwinds Network Performance Monitor (NPM) có các tính năng bao gồm khám phá mạng, giám sát tính khả dụng (ví dụ: các node up/down), health status (như CPU usage), performance monitoring (interface bandwidth utilization) v.v..

Lab này cũng bao gồm các sản phẩm khác của SolarWinds bao gồm Network Configuration Manager (NCM) và NetFlow Traffic Analyzer (NTA) nhưng chúng tôi sẽ hạn chế đề cập & chỉ tập trung vào Solarwinds Network Performance Monitor (NPM).

Lab Setup

Để làm cho bài viết này thực tế nhất có thể, chúng tôi sẽ cài đặt Solarwinds Network Performance Monitor (NPM) để giám sát (monitor) Windows Server 2012 và hai bộ định tuyến (router) của Cisco trong môi trường lab này.

Lab được setup như hình bên dưới

  • Chúng tôi sử dụng gói AWS EC2 và sau đó Solarwinds Network Performance Monitor (NPM) sẽ được cài đặt.
  • Windows Server 2012 R2 sẽ làm HĐH (hệ điều hành) cơ sở mặc dù Windows Server 2012 và Windows Server 2016 cũng được SolarMinds NPM hỗ trợ.
  • Đối với khía cạnh kết nối mạng (networking), chúng tôi sử dụng phần mềm GNS3 để mô phỏng các bộ định tuyến (router).

Để tạo một mạng giữa Windows Server và Lab GNS3, chúng tôi đã tạo một loopback interface trên Windows Server và sau đó kết nối một trong các bộ định tuyến (router) với interface loopback này.

Trợ giúp cho bạn

Thêm interface loopback cho các hệ điều hành Windows mới rất đơn giản. Chỉ cần tìm kiếm Loopback Manager và ô gõ lệnh sẽ tự động mở ra.

Cấu hình trên các bộ định tuyến rất đơn giản: IP addresses, EIGRP & SNMP community strings. Sau đây là cấu hình trên R1

hostname R1

!

ip domain name example.com

username cisco privilege 15 secret cisco123

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 10.11.12.1 255.255.255.0

no shutdown

!

interface FastEthernet0/1

ip address 10.12.13.1 255.255.255.0

no shutdown

!

router eigrp 10

network 0.0.0.0

no auto-summary

!

snmp-server community cisco123 RO

!

line vty 0 4

login local

!

Cấu hình trên R2

hostname R2

!

username cisco privilege 15 secret cisco123

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 10.12.13.2 255.255.255.0

no shutdown

!

router eigrp 10

network 0.0.0.0

no auto-summary

!

snmp-server community cisco123 RO

!

line vty 0 4

login local

!

Lưu ý: Để làm cho R2 có thể truy cập từ Windows Server, bạn có thể thêm một static route với dòng lệnh:

route add 10.12.13.0 mask 255.255.255.0 10.11.12.1

Kiểm tra kết quả bằng dòng lệnh ping

Cài đặt Solarwinds Network Performance Monitor (NPM)

Sau khi thiết lập lab, bây giờ là cài đặt & thiết lập NPM SolarWinds.

Trong phần này, chúng tôi sẽ nói về việc cài đặt NPM, Network Discovery, Alerts, Reports và một số tính năng khác

Pre-Installation & System Requirements

Bản cài đặt offline có dung lượng trên 2 GB (mặc dù bản cài đặt online chỉ 50MB). Khách hàng có thể dùng thử với Đăng ký, tải bản dùng thử 30 ngày

Sau khi đăng ký, tệp cài đặt yêu cầu kết nối Internet sẽ bắt đầu được tải xuống tự động. Ở bên phải màn hình, bạn sẽ thấy tùy chọn tải xuống phiên bản online & là phiên bản sẽ được sử dụng trong bài viết này.

Yêu cầu hệ thống cho Solarwinds Network Performance Monitor (NPM) cũng khá cao, đặc biệt là với phiên bản mới nhất (kể từ khi viết bài này là phiên bản 12.2). Sau đây là các yêu cầu tối thiểu:

  • Quad-Core Processor CPU
  • 6GB of RAM
  • 20GB of hard disk space

Quá trình cài đặt

Việc cài đặt Solarwinds Network Performance Monitor (NPM) khá đơn giản. Bạn có thể chọn 2 phiên bản: Lightweight: bản nhẹ, Standard: bản tiêu chuẩn.

  • Bản Lightweight thích hợp cho Solarwinds Network Performance Monitor (NPM) & SQL Server Express ở cùng server
  • Bản Standard thích hợp cho các môi trường sản xuất và yêu cầu SQL Server 2012+ riêng biệt.

Đối với bài viết này, chúng tôi sẽ demo bản Lightweight

SolarWinds sẽ yêu cầu nhập email rất nhiều và bạn sẽ cần nhập email trước khi cài đặt phần mềm.

Điểm đáng chú ý là người dùng có thể chọn thêm các phần mềm khác của Solarwinds trong quá trình cài đặt. Trong demo này chúng tôi chỉ chọn Solarwinds NPM.

Tiếp theo, cài đặt sẽ chạy kiểm tra để đảm bảo rằng máy chủ mà NPM sẽ được cài đặt đáp ứng đủ các yêu cầu.

Như bạn sẽ thấy trong trường hợp demo này, ngay cả 4 vCPUs cũng không đủ. Tuy nhiên, với mục đích demo, điều này sẽ không quá ảnh hưởng so với điều kiện & môi trường thực tế.

Sau khi qua bước kiếm tra cấu hình, chọn accept vào điều khoản người dùng end user license agreement

Khi NPM SolarWinds đã được cài đặt, bạn cần các thành phần khác như Microsoft IIS. Việc cài đặt mất khoảng 15 phút để hoàn thành.

Khi kết thúc cài đặt , Orion web console  sẽ tự động mở trong trình duyệt mặc định của bạn.

Cổng (port) mặc định được sử dụng cho bảng điều khiển web là 8787.

Nếu cài đặt bản standard, bạn sẽ có tùy chọn để thay đổi port, chẳng hạn như Port 80.

Có thể bạn quan tâm: Tìm hiểu về Solarwinds Orion

Username mặc định là admin, mật khẩu để trống -> chỉ cần nhấp login là có thể đăng nhập được.

Lưu ý: Bạn cũng có thể mở Orion Web Console như bất kỳ ứng dụng thông thường nào trên windows.

Review

Khi mở web console, bạn sẽ thấy trang Discovery Central cho phép bạn tự động khám phá mạng hoặc thêm các node.

Trong trường hợp demo này có 1 node để theo dõi.

Local server là nơi cài đặt NPM SolarWinds – cho nên không cần phải làm thêm bước gì khác để giám sát local server.

Trước khi thực hiện bất kỳ khám phá mạng nào (network discovery), hãy xem các thông tin mà phần mềm cung cấp cho bạn, thực hiện điều hướng sau:

MY DASHBOARDS -> Summary (dưới Home)

Lưu ý: Nếu bạn cài đặt nhiều sản phẩm SolarWinds hơn, menu MY DASHBOARD sẽ bao gồm nhiều phần phụ hơn HOME và NETWORK.

Ở trang Summary page (có thể sắp xếp theo ý), có thể thấy một danh sách các nodes, active alerts, summary of events, maps, groups v.v.

Điểm đáng lưu ý là, khi rê chuột trên 1 node bất kì, phần mềm sẽ hiển thị cho thấy thông tin tóm tắt về node đó như hình bên dưới sau

Khi click vào node, các thông tin chi tiết sẽ được liệt kê rất đầy đủ

Network Discovery

Để review tính năng này cho các router của Cisco trong demo, tiến hành điều hướng (tương tự trong môi trường thực tế của bạn):

SETTINGS → Network Discovery

Bảng hướng dẫn Network Sonar Wizard sẽ hiển thị, sau đó chọn địa chỉ / mạng con IP (P addresses/subnets) nào để quét, thông tin đăng nhập và nhập thiết bị được phát hiện.

Các thông tin bao gồm:

  • IP addresses ranges.
  • Subnets có thể được phát hiện với seed router.
  • Individual IP addresses.
  • Querying Active Directory Domain Controller.

Lựa chọn Seed Router cho phép chỉ định một địa chỉ IP và công cụ khám phá sẽ bắt đầu quét từ bộ định tuyến đó và sau đó nhảy từ thiết bị đó để khám phá các thiết bị khác.

Ở bước tiếp theo, bạn có thể chọn poll cho cập nhật từ tất cả các node hiện đang được thăm dò bởi các agent. Trong trường hợp của demo, chỉ có local server có một agent đang chạy.

Ở bước này, phần mềm sẽ hỏi bạn về VMware systems, nếu không sử dụng, chỉ cần chọn bỏ.

Cài đặt SNMP credentials. SNMP là một trong những công cụ quan trọng nhất để giám sát và quản lý mạng. SNMP tốn rất ít tài nguyên mạng (bandwidth, CPU) và thường hoạt động bình thường với firewall và kết nối NAT.

Như bạn có thể thấy, mặc định của community strings là “public” hoặc “private”. Vì lý do bảo mật, bạn không bao giờ nên sử dụng các community strings này trong môi trường mạng của mình, nếu có thể, hãy dùng SNMPv3 thay thế.

Trong demo này chúng tôi sẽ tạo community string mới tên là Cisco123 (SNMPv2c) được cấu hình ở Cisco router.

Cài đặt WMI credentials. Để sử dụng WMI, sẽ dễ dàng hơn nếu Active Directory cũng được sử dụng trong môi trường để có thể sử dụng một domain/username/password cho tất cả các máy chủ thay vì một kết hợp cho mỗi máy chủ.

Cài đặt monitor. Bước này giúp bạn xác định cách monitor các thiết bị – hoặc là chọn các thiết bị một cách thủ công, hoặc là tạo “blanket” với các tuỳ chỉnh cho tất cả các thiết bị.

Discovery settings. Bước này, chúng ta có thể tùy chỉnh các cài đặt của khám phá thiết bị như tên, mô tả, thời gian chờ SNMP, v.v.

Một tùy chọn rất hữu ích trên trang cài đặt này là Hop Count, cho phép Network Sonar Wizard mở rộng khám phá của mình sang các bước khác của một thiết bị được phát hiện.

Ví dụ: chỉ thêm các mạng con 10.11.12.0/24 và 10.12.13.0/24 trong khám phá thiết bị (discovery), Network Sonar Wizard sẽ khám phá các thiết bị trong các mạng con đó.

Tuy nhiên, hãy hình dung rằng R2 cũng được kết nối với một mạng con khác (ví dụ: 10.13.14.0/24). Bằng cách tăng số lượng hop lên mức lớn hơn 0, Network Sonar Wizard sẽ cố gắng khám phá các thiết bị trong mạng con đó.

Giá trị số bước nhảy tối đa là 10 và bạn nên cẩn thận với cài đặt này vì có thể làm Network Sonar Wizard hoạt động sai.

Discovery Scheduling. bước cuối cùng, chúng ta có thể lên lịch tần suất quét của khám phá thiết bị (discovery).

Các tùy chọn bao gồm một lần, hàng giờ, hàng ngày và nâng cao cho phép bạn chọn ngày / lần cụ thể để chạy khám phá.

Sau các bước trên, phần mềm đã sẵn sàng khả năng khám phá mạng. Khả năng khám phá mạng & thiết bị có thể sử dụng ở bất cứ đâu và thường mất từ vài phút đến vài giờ tuỳ thuộc vào độ rộng của Network & cấu hình (chẳng hạng như số Hop Count).

Trong bài demo này, quá trình khám phá chỉ vài phút và hiển thị thông tin về các node như hình bên dưới:

Bạn có thể chọn và / hoặc bỏ chọn các node đang monitor.

Cuối cùng, phần mềm sẽ cung cấp một bản xem trước các node mà bạn có thể import hoặc export vào monitoring database.

Nếu quay trở lại trang Sumary, phần mềm sẽ cho thấy 2 router và cả Windows server.

Tương tự như các nodes, rê chuột hoặc click vào Windows server để nắm được thêm thông tin chi tiết.

Có nhiều tác vụ có thể thực hiện ngay lúc này với Orion web console như mở kết nối SSH đến các node sử dụng Performance Analyzer.

Nếu bạn di chuyển chuột sang bên trái màn hình, bạn cũng có thể xem thêm thông tin của một node như thống kê quan trọng và thống kê mạng.

Cài đặt Alert trong Solarwinds Network Performance Monitor (NPM)

Ngoài việc hiển thị cảnh báo trên bảng điều khiển web, một giải pháp giám sát mạng tốt cũng sẽ cung cấp các cách khác để thông báo cho người dùng về những điều xảy ra trên mạng. Giống như những tính năng khác mà SolarWinds NPM làm rất tốt, phần mềm có một hệ thống cảnh báo tuyệt vời.

Demo sẽ thiết lập một cảnh báo (alert) mới cho R1 để nếu một interface bị down hơn 2 phút, phần mềm sẽ gửi email đến quản trị viên.

Để bắt đầu, chỉ cần nhấp vào nút Add New Alert

Điều hướng sau cũng cho bạn khả năng tạo thông báo: ALERTS & ACTIVITY → Alerts → Manage Alerts  click ADD NEW ALERT dưới tab ALERT MANAGER.

Bước đầu tiên là định cấu hình các thuộc tính cảnh báo bao gồm tên, mô tả, tần suất đánh giá điều kiện kích hoạt, mức độ nghiêm trọng của cảnh báo (ví dụ: quan trọng, thông báo, cảnh báo) và thậm chí cả danh mục người dùng nên có quyền truy cập vào cảnh giác.

Bước tiếp theo là cấu hình trigger – tức điều kiện kích hoạt alert:

  1. Trigger có thể được chọntrên node, interface, group, VLANs và nhiều đối tượng khác.
  2. Bạn cũng có thể định cấu hình phạm vi cảnh báo, cho dù nó nên áp dụng cho tất cả các đối tượng trong môi trường của bạn hoặc cho các đối tượng cụ thể đáp ứng các tiêu chí nhất định.
  3. Cuối cùng, bạn có thể tự định cấu hình điều kiện kích hoạt, ví dụ: nếu một giao diện bị hỏng hoặc bị tắt. Bạn cũng có thể chỉ định khoảng thời gian điều kiện sẽ tồn tại trước khi cảnh báo được kích hoạt.

Để bỏ cảnh báo, chọn reset hoặc xoá đi như ảnh dưới đây

Chọn thời gian cảnh báo

Bước quan trọng tiếp theo, sau khi các điều kiện đã được cấu hình cho alert, bạn cần chọn hành động (action) khi trigger được kích hoạt. Theo mặc định, cảnh báo sẽ được hiển thị trong trang Active Alerts của web console.

Phần mềm hỗ trợ các hành động khác như gửi SMS, email, syslog message, thực thi một script và nhiều hơn thế nữa.

Xin hãy lưu ý, trong trường hợp action là gửi email, bạn cần phải cấu hình SMTP server.

Thật không may, NPM SolarWinds không đi kèm với máy chủ SMTP của riêng nó nên bạn phải có và định cấu hình của riêng bạn (điều này không phải là vấn đề cho lắm).

Cuối cùng, bạn có thể đặt hành động đặt lại là hành động nên được thực hiện khi cảnh báo đã được xóa.

Submit, xem lại nếu cần chỉnh sửa và bạn đã hoàn tất bước này.

Ngay lập tức, phần mềm sẽ điều hướng bạn đến trang ALERT MANAGER.

Kiểm tra kết quả

Tại R1, interface loopback sẽ được shutdown với lệnh:

interface lo0

shutdown

Mặc dù cảnh báo đã tạo chưa kích hoạt ngay lập tức, chúng ta vẫn sẽ thấy sự thay đổi trong trang Events page ở web console.

Sau khoảng 2 phút, bắt đầu kiểm tra thử ( điều hướng ALERTS & ACTIVITY → Alerts)

Click để biết thêm chi tiết

Report

Điều hướng REPORTS → All Reports để thấy các template (mẫu) báo cáo được làm sẵn.

Có hơn 70 báo cáo web mặc định và bạn cũng có thể tự tạo riêng cho mình nếu muốn.

Chúng tôi sẽ lấy một template (mẫu) báo cáo như 1 ví dụ cho bạn dễ hình dung, mẫu của Average CPU Utilization – This Week

Kết luận

Phần mềm khuyên dùng !

SolarWinds NPM là một công cụ giám sát mạng thực sự tuyệt vời, phần mềm có thể cung cấp nhiều thông tin như tính khả dụng, theo dõi sức khỏe và hiệu suất, phân tích băng thông. Phần mềm có một công cụ tuyệt vời để thực hiện khám phá mạng và cung cấp các báo cáo và cảnh báo tùy biến cao. Hơn nữa, các sản phẩm SolarWinds khác có thể được thêm vào để mở rộng chức năng của NPM.

Điểm trừ nhỏ của phần mềm này là khả năng khổng lồ của NPM đòi hỏi “bộ đồ nghề” khá cồng kênhg. Bạn sẽ cần một máy chủ có thể xử lý các tùy chọn mà NPM của Solarwinds cung cấp cho bạn cũng như môi trường CNTT của bạn có một lượng lớn dữ liệu và phân tích để thực sự tận dụng tối đa hết các khả năng của phần mềm này.

SolarWinds có giá cạnh tranh để theo dõi 100 elements. Một element có thể là interface, node hoặc volume. Để hiểu thêm về chính sách cấp phép cũng như được báo giá tốt vui tham khảo bài viết mua Solarwinds Network Performance Monitor hoặc liên hệ trực tiếp chúng tôi để nhận được hỗ trợ từ chuyên viên kỹ thuật & kinh doanh:

Ngoài ra, bạn có thể xem chi tiết license của mình bằng cách điều hướng sau: SETTINGS → All Settings → License Details.

guest
0 Comments
Inline Feedbacks
View all comments

Bài viết liên quan

Pin It on Pinterest

Share This